Jump to content

The Leica Forum uses cookies. Read the privacy statement for more info. To remove this message, please click the button to the right:    OK, understood.

Photo

SL manual lens profile disabled with non-Leica lens?


  • Please log in to reply
5 replies to this topic

#1 leicatraveller

leicatraveller

    Erfahrener Benutzer

  • Members
  • 359 posts

Posted 17 February 2017 - 16:37

Advertisement (Gone after free registration)

hello guys, i have one problem, when i try to use some old voigtlander lens on my SL the lens profile menu is disabled , i can't have access.  :huh:  :huh:  :huh:

 

some solution for me ?

thanx to all 

 

 



#2 Alo Ako

Alo Ako

    Erfahrener Benutzer

  • Members
  • 343 posts
  • LocationHamburg

Posted 17 February 2017 - 16:45

some solution for me ?

 

No. Waiting for Update and hopefully....maybe....


Danke für Deine Aufmerksamkeit, thanks for your attention,

Horst


#3 leicatraveller

leicatraveller

    Erfahrener Benutzer

  • Members
  • 359 posts

Posted 17 February 2017 - 17:06

No. Waiting for Update and hopefully....maybe....

 

very bad Leica  :wacko:

 

so just M mode...



#4 ramarren

ramarren

    Erfahrener Benutzer

  • Members
  • 3,235 posts

Posted 17 February 2017 - 18:11

Are these M-mount lenses? Or what?

With M-mount lenses, as long as you use the M Adapter L, you can manually select the lens profile for any non-six-bit coded lens. The lens profiles are, of course, all for Leica lenses, so you have to figure out which lens profile suits your Voigtländer lens best. That depends on the lens design and the individual profiles.

Third party mount adapters (Novoflex and the like) do not have the electronics that tell the SL body that a Leica M-mount lens is fitted.

I don't know what you mean by "... so just M mode". With adapted lenses, you always have Aperture priority and Manual exposure modes.

Edited by ramarren, 17 February 2017 - 18:12.


#5 CrisRose

CrisRose

    Erfahrener Benutzer

  • Members
  • 149 posts

Posted 17 February 2017 - 23:30

I have several VM lenses and they work fine - 35/1.4 Nokton and the 15/4.5 MkII for example

#6 Ario Arioldi

Ario Arioldi

    Erfahrener Benutzer

  • Members
  • 502 posts
  • City / Ort:Milano

Posted 18 February 2017 - 03:06

Usually when the lens profile menu is disabled it is because the lens is recognized as a 6 bit coded lens. This may be caused by a screw or by some mark on the lens mount wrongly identified as a dot. I have experienced that also with some uncoded Leica lens.




0 user(s) are reading this topic